www.racing-cars.com Homepage
Forum Home Forum Home > Nitro > Nitro Touring
  New Posts New Posts RSS Feed - Glow Plugs
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Glow Plugs

 Post Reply Post Reply
Author
Message
kiwi7 View Drop Down
Senior Member
Senior Member
Avatar

Joined: 27 October 2004
Status: Offline
Points: 1383
Post Options Post Options   Thanks (0) Thanks(0)   Quote kiwi7 Quote  Post ReplyReply Direct Link To This Post Topic: Glow Plugs
    Posted: 22 January 2005 at 5:40pm
What is the best way to check if they are still working good?
Back to Top
Guests View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Guests Quote  Post ReplyReply Direct Link To This Post Posted: 22 January 2005 at 6:01pm
take em out and light em up witht ths glow plug starter or if u wanna do it my way, clear a lil spot on a desk in ur bedroom like i did put some fuel on my desk and see if it would light it easily enough which it did so i knew it would be fine
Back to Top
kiwi7 View Drop Down
Senior Member
Senior Member
Avatar

Joined: 27 October 2004
Status: Offline
Points: 1383
Post Options Post Options   Thanks (0) Thanks(0)   Quote kiwi7 Quote  Post ReplyReply Direct Link To This Post Posted: 22 January 2005 at 6:03pm
Interesting approach, I might set the desk a light if I use fuel mate
Back to Top
kiwi7 View Drop Down
Senior Member
Senior Member
Avatar

Joined: 27 October 2004
Status: Offline
Points: 1383
Post Options Post Options   Thanks (0) Thanks(0)   Quote kiwi7 Quote  Post ReplyReply Direct Link To This Post Posted: 22 January 2005 at 6:09pm
Ok I  puti the glow starter, the coil heats to red in the centre part of the plug but should it get red all the way to the bitr that sits flush at the top of the plug? The end of the coils I mean?
Back to Top
Guests View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Guests Quote  Post ReplyReply Direct Link To This Post Posted: 22 January 2005 at 6:22pm
ye mine does well all 4 of mine do so ye thats kool
Back to Top
kiwi7 View Drop Down
Senior Member
Senior Member
Avatar

Joined: 27 October 2004
Status: Offline
Points: 1383
Post Options Post Options   Thanks (0) Thanks(0)   Quote kiwi7 Quote  Post ReplyReply Direct Link To This Post Posted: 22 January 2005 at 6:28pm
I have a small prob with my car today and I thought it may have something  to do with this. My car starts fine and idles nicely ( actually revs a little to high at idle) I give it a few revs with my controller and then when I remove the glow starter the revs drop and the ebgine dies? Any ideas, as it is obvisously not the glow plug then!!!!!!!
Back to Top
cyberglass View Drop Down
Senior Member
Senior Member
Avatar

Joined: 30 December 2004
Location: United Kingdom
Status: Offline
Points: 354
Post Options Post Options   Thanks (0) Thanks(0)   Quote cyberglass Quote  Post ReplyReply Direct Link To This Post Posted: 22 January 2005 at 9:08pm

put some fuel on my desk and see if it would light it easily enough

 

 i burned down my house

Back to Top
sirus View Drop Down
Senior Member
Senior Member
Avatar

Joined: 14 July 2004
Location: Australia
Status: Offline
Points: 1856
Post Options Post Options   Thanks (0) Thanks(0)   Quote sirus Quote  Post ReplyReply Direct Link To This Post Posted: 22 January 2005 at 9:53pm
running to lean i think, tho im bad a tuning :P ask one of the more pro people.
Back to Top
kiwi7 View Drop Down
Senior Member
Senior Member
Avatar

Joined: 27 October 2004
Status: Offline
Points: 1383
Post Options Post Options   Thanks (0) Thanks(0)   Quote kiwi7 Quote  Post ReplyReply Direct Link To This Post Posted: 22 January 2005 at 10:16pm
I thought it might be that I wll have a play with it tomorrow, cheers mate
Back to Top
sirus View Drop Down
Senior Member
Senior Member
Avatar

Joined: 14 July 2004
Location: Australia
Status: Offline
Points: 1856
Post Options Post Options   Thanks (0) Thanks(0)   Quote sirus Quote  Post ReplyReply Direct Link To This Post Posted: 23 January 2005 at 1:07am
jus b carefull because it might be your exhaust not pushing enough air through to keep it running, check for holes, or if its started to pump abit of oil through to ur tank
Back to Top
beltakidda View Drop Down
Groupie
Groupie
Avatar

Joined: 13 January 2005
Location: United Kingdom
Status: Offline
Points: 54
Post Options Post Options   Thanks (0) Thanks(0)   Quote beltakidda Quote  Post ReplyReply Direct Link To This Post Posted: 23 January 2005 at 8:09pm
kiwi that happened to me the other day. i dont know wot caused it by i started the engine back up and it hasnt happened again..

wierd
Back to Top
kiwi7 View Drop Down
Senior Member
Senior Member
Avatar

Joined: 27 October 2004
Status: Offline
Points: 1383
Post Options Post Options   Thanks (0) Thanks(0)   Quote kiwi7 Quote  Post ReplyReply Direct Link To This Post Posted: 23 January 2005 at 8:23pm
Just too cold I think, needed richer mixture.Now running sweet.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.01
Copyright ©2001-2011 Web Wiz Ltd.

This page was generated in 0.078 seconds.